Gentoo Archives: gentoo-alt

From: Jeremy Olexa <darkside@g.o>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] [PREFIX] there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]".
Date: Fri, 15 Jun 2012 18:21:52
Message-Id: CAMxqorWH2u5G6ms6VesSrT62ihrpx_+zyggfr0tTes+egDNgwQ@mail.gmail.com
In Reply to: [gentoo-alt] [PREFIX] there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]". by Asfand Qazi
On Fri, Jun 15, 2012 at 9:44 AM, Asfand Qazi <aq2@×××××××××.uk> wrote:
> Hello, when I've been trying to do a emerge -DuvNta world recently, this is > what I've been getting: > > emerge: there are no ebuilds to satisfy "app-text/ghostscript-gpl[cups]". > (dependency required by "net-print/cups-1.5.3" [ebuild]) > (dependency required by "dev-java/icedtea-bin-7.2.1-r1[X]" [ebuild]) > (dependency required by "@selected" [set]) > (dependency required by "@world" [argument]) > > I can create my own ebuild in my local overlay, but is there a more > permanent fix to this?
USE=cups is masked. icedtea-bin[X] requires cups. icedtea-bin is not keyworded for Gentoo Prefix. With that above info, we have already taken care of protecting users who are not hacking on Gentoo Prefix. After looking at the icedtea-bin ebuild, looks like you can disable USE=X and install it without cups? Good luck, you are in untested/unsupported territory, Jeremy

Replies